Building GCC for Cortex

classic Classic list List threaded Threaded
1 message Options
BogdanM BogdanM
Reply | Threaded
Open this post in threaded view

Building GCC for Cortex

Yes, sorry about that, forgot to update. Apparently, binutils 2.19.1 is
broken (at least on ARM builds), so use

Everything else should remain unchanged.


On Thu, Feb 19, 2009 at 2:06 PM, John Hind <john.hind at> wrote:

> I am trying to follow the tutorial "Building GCC for Cortex", but I am new
> to Ubuntu and am running into the sand at Step 1 (the easiest step!). As it
> has already taken me several hours of head-banging to get this far, I am
> appealing for help!
> The problem starts with the "make all" step (for binutils). It terminates
> with "make: *** [all] Error 2". A few lines above this there are 5
> occurrences of "tc-arm.c: xxxx: error: format not a string literal and no
> format arguments".
> I have tried the complete procedure to this point several times, with both
> the latest release (binutils-2.19.1.tar.bz2) and the recommended one
> (binutils-2.19.tar.bz2) always with the same result. This on a fresh
> installation of Ubuntu 8.10 Desktop.
> Anyone solved this one before or do I need to do some more head-banging?
> _______________________________________________
> Elua-dev mailing list
> Elua-dev at
-------------- next part --------------
An HTML attachment was scrubbed...